<!DOCTYPE HTML PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xml:lang="en" xmlns="http://www.w3.org/1999/xhtml" lang="en">
<head>
<title>Indigenous First Nations in Saskatchewan to get biomass power | Biomassmagazine.com</title>

<meta name="og:description" content="Turboden S.p.A. has concluded a contract to provide the Meadow Lake Tribal Council, representing nine Indigenous First Nations in Saskatchewan, Canada, with an 8,000 kW ORC power generation system that uses sawmill residual woody biomass as fuel.  " /> 
<meta name="description" content="Turboden S.p.A. has concluded a contract to provide the Meadow Lake Tribal Council, representing nine Indigenous First Nations in Saskatchewan, Canada, with an 8,000 kW ORC power generation system that uses sawmill residual woody biomass as fuel.  " /> 
<meta name="keywords" content="Indigenous First Nations in Saskatchewan to get biomass power | Biomassmagazine.com,biomass power and thermal, biomass, power, energy, renewable, thermal, pellets, pellet mills, biomass pricing, biomass news, bioenergy news, advanced biofuels, biobased chemicals, policy, news, pellet producers" />
<meta name="robots" content="index, follow" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@BiomassMagazine" />
<meta name="twitter:title" content="Indigenous First Nations in Saskatchewan to get biomass power @BiomassMagazine" />
<meta name="twitter:description" content="Turboden S.p.A. has concluded a contract to provide the Meadow Lake Tribal Council, representing nine Indigenous First Nations in Saskatchewan, Canada, with an 8,000 kW ORC power generation system that uses sawmill residual woody biomass as fuel. " />
<meta name="twitter:image" content="http://biomassmagazine.com/uploads/posts/web/2020/02/Indigenous-First-Nations-Turboden_15814349562045.jpeg" />


<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />

	<link rel="stylesheet" type="text/css" href="/css/reset.css" />
	<link rel="stylesheet" type="text/css" href="/css/public.css" />

	<script type="text/javascript" src="/js/jquery-1.4.2.min.js"></script>
	<script type="text/javascript" src="/js/jquery.twitter.js"></script>
	<script type="text/javascript" src="/js/jquery.bxGallery.js"></script>
	<script type="text/javascript" src="/js/jquery.hint.js"></script>
<script type="text/javascript">
$(document).ready(function(){
	$('input[title!=""]').hint();
	$('#searchButton').click(function() {
  		$('#searchForm').submit();
	});
});
</script>

<script type="text/javascript" src="/js/jquery.lightbox-0.5.js"></script>
<link href="/css/jquery.lightbox-0.5.css" rel="stylesheet" type="text/css" />
<script type="text/javascript">
	$(document).ready(function(){
		$('#imageGallery').bxGallery({
			maxheight: 0,
			thumbwidth:50,
			thumbplacement: 'top',
			thumbcrop: true,
			opacity: .5
		});
		$('#imageGallery li a').lightBox();
	});
</script>

<style type="text/css">
p{font-size:10.5pt}
.outer{float: right; margin-left: 20px; width:300px;}
.ad{float: right; margin-left: 20px; width:100%;text-align: center;padding-bottom: 30px;}
/* .outer:after{content:".";display:block;height:0;clear:both;visibility:hidden; } */
.ad:after{content:".";display:block;height:0;clear:both;visibility:hidden; }
.thumbs{margin-bottom: 5px;}
.thumbs li{margin-right: 5px; float: left;}
			.thumbs li{display: none;}
	.caption{font-size: 11px; min-height: 80px;}
.caption:after{content:".";display:block;height:0;clear:both;visibility:hidden; }
.caption small{color: grey;}

</style>

<script type='text/javascript'><!--// <![CDATA[
var OA_zones = {
'leaderboard' : 43,
'rectangle_1' : 42,
'rectangle_2' : 42,
'rectangle_3' : 42,
'med_rectangle_1' : 41,
'med_rectangle_2' : 41,
'skyscraper' : 40
}
// ]]> -->
</script>
<script type="text/javascript" src="//platform-api.sharethis.com/js/sharethis.js#property=58d924663059c000121c8be9&product=inline-share-buttons"></script>
<script type="text/javascript" src="http://adserver.bbibiofuels.com/www/delivery/spcjs.php?id=6&amp;blockcampaign=1&amp;target=_blank"></script>


<script type="text/javascript">
var timeout         = 500;
var closetimer		= 0;
var ddmenuitem      = 0;

function jsddm_open()
{	jsddm_canceltimer();
	jsddm_close();
	ddmenuitem = $(this).find('ul').eq(0).css('visibility', 'visible');}

function jsddm_close()
{	if(ddmenuitem) ddmenuitem.css('visibility', 'hidden');}

function jsddm_timer()
{	closetimer = window.setTimeout(jsddm_close, timeout);}

function jsddm_canceltimer()
{	if(closetimer)
	{	window.clearTimeout(closetimer);
		closetimer = null;}}

$(document).ready(function()
{	$('#dropMenu > li').bind('mouseover', jsddm_open);
	$('#dropMenu > li').bind('mouseout',  jsddm_timer);});

document.onclick = jsddm_close;
</script>
<link href="/css/print.css" media="print" rel="stylesheet" />
<script src='https://www.google.com/recaptcha/api.js'></script>
</head>

<body>

<script type="text/javascript" src="/js/jquery.ui.1.7.2.js"></script>
<link rel="stylesheet" type="text/css" href="/css/ui-lightness/jquery-ui-1.8.5.custom.css" />


<script type='text/javascript'>
    $(function() {
        $('#brmWelcome').dialog({modal: true, title: 'Attention Biorefining Readers'});
  });
</script>

<div id="header">
	<div id="mainMenu">
		<div class="content">
			<div class="left">
				
		<ul id="dropMenu">
				<li><a href="/">HOME</a></li>
				<li><a href="#" class="magazine">MAGAZINE</a>
					<ul>
						<li><a href="/issues/browse/">CURRENT ISSUE</a></li>
						<li><a href="/pellet-mill-magazine/">PELLET MILL MAGAZINE</a></li>
						<li><a href="/issues/archives/">SEARCH ARCHIVES</a></li>
					</ul>
				</li>
				
				<li><a href="#">E-NEWSLETTERS</a>
					<ul>
						<li><a href="/newsletter/biomass-week/">BIOMASS WEEK</a></li>
						<li><a href="/newsletter/pellet-mill-press/">PELLET MILL PRESS</a></li>
					</ul>
				</li>
				<li><a href="/videos/browse/">VIDEOS</a></li>
				<li><a href="#">EVENTS</a>
				<ul>
				<li><a href="/events/browse/">CONFERENCES</a></li>
				<li><a href="/pages/webinar/">WEBINARS</a></li>
				</ul>
				</li>
				<li><a href="#">PLANTS</a>
					<ul style="width:250px">
						<li style="width:200px"><a style="width:200px" href="/plants/listplants/biomass/US/page:1/sort:plant/direction:asc">BIOMASS POWER LIST</a></li>
						<li style="width:200px"><a  style="width:200px" href="/plants/map/biomass/">BIOMASS POWER MAP</a></li>
						<li style="width:200px"><a style="width:200px" href="/plants/listplants/pellet/US/page:1/sort:plant/direction:asc">PELLET PRODUCERS LIST</a></li>
						<li style="width:200px"><a style="width:200px" href="/plants/map/pellet/">PELLET PRODUCERS MAP</a></li>
						<li style="width:200px"><a style="width:200px" href="/plants/listplants/biogas/US/page:1/sort:plant/direction:asc">BIOGAS PRODUCERS LIST  <span style="color:red">BETA</span></a></li>
						<li style="width:200px"><a style="width:200px" href="/plants/map/biogas/">BIOGAS PRODUCERS MAP  <span style="color:red">BETA</span></a></li>
					</ul>
				</li>
				<li><a href="/pages/subscribe/">SUBSCRIBE</a></li>
				<li><a href="http://directory.biomassmagazine.com" class="last">DIRECTORY</a>
					<ul>
						<li><a href="http://directory.biomassmagazine.com">ONLINE LISTINGS</a></li>
						<li><a href="/pages/print_issue/">PRINT ISSUE</a></li>
					</ul>
				</li>

				
				
			</ul><!-- end #dropMenu -->
					</div> <!-- end .left -->
			<div class="right">
				<span>Follow us on</span>
									<a href="https://www.google.com/+Biomassmagazine" target="_blank"><img style="max-height:23px; max-width:24px;" src="/img/layout/googleplus.png" /></a>
				<a href="http://twitter.com/#!/biomassmagazine" target="_blank"><img src="/img/layout/twitter.jpg" /></a>
				<a href="http://www.facebook.com/BiomassMag" target="_blank"><img src="/img/layout/facebook.jpg" /></a>
				<a href="/rss.xml" target="_blank"><img src="/img/layout/rss.png" /></a>
			</div><!-- end .right -->
		</div><!-- end .content -->
	</div><!-- end #mainMenu -->
	<div id="logoHeader">
		<div class="content">
			<div id="logo"><a href="/"><img src="/img/layout/headerLogo.jpg"></a></div>
			
			<div id="topAd">		
				<script type='text/javascript'>
			    	OA_show('leaderboard');
			    </script>
			</div>
		</div>
	</div>
	<div id="menuHeader">
		<div class="content">
				
			<ul>
				<li><a href="/tag/pellets/">Pellets</a></li>
				<li><a href="/tag/power/">Power</a></li>
				<li><a href="/tag/thermal/">Thermal</a></li>
				<li><a href="/tag/biogas/">Biogas</a></li>
				<li><a href="/tag/advanced_fuels/">Advanced Biofuels</a></li>
				<li><a href="/tag/chemicals/" class="last">Chemicals</a></li>
			</ul>
						
			<div id="search">
				<form action="/search/" method="post" id="searchForm">
					<input type="text" id="searchBox" name="data[search]" title="Search Biomass Magazine" /> 
					<input type="button" id="searchButton" value="search">
				</form>
			</div><!-- end #search -->
		</div>
	</div>
</div>
<div id="mainContainer">	
	<div class="content">
		<div class="pad20">	





<div id="colLeft">
	<div class="floatRight">

	</div>





<div >
	<div class="sharethis-inline-share-buttons"></div>
	</div>
<div class="post">
	<h1>Indigenous First Nations in Saskatchewan to get biomass power</h1>
	<div class="author">By Turboden  | February 11, 2020</div><div class="body"><ul id="imageGallery" class="clearFix""><li><a href="/uploads/posts/web/2020/02/Indigenous-First-Nations-Turboden_15814349562045.jpeg">
						<img src="/uploads/posts/web/2020/02/resize/Indigenous-First-Nations-Turboden_15814349562045-300x300-noup.jpeg" title="&lt;br&gt;&lt;small&gt;Photo: Turboden S.p.A.&lt/small&gt;" />
					</a></li></ul><div class="ad"><div class="advertisement">ADVERTISEMENT</div> <script type="text/javascript">OA_show("med_rectangle_1");</script></div><p>Turboden S.p.A., a group company of Mitsubishi Heavy Industries Ltd. based in Brescia, Italy, has concluded a contract to provide the Meadow Lake Tribal Council, representing nine Indigenous First Nations in Saskatchewan, Canada, with an 8,000 kW Organic Rankine Cycle power generation system that uses sawmill residual woody biomass as fuel.</p>
<p>The carbon-neutral power project, operating under the name of the MLTC Bioenergy Centre, will be located near Meadow Lake, Saskatchewan, within the traditional territory of the nine First Nations of the Meadow Lake Tribal Council.</p>
<p>The green power generation facility, with major equipment supplied by Turboden, is a project of the Meadow Lake Tribal Council, supported with funding from the government of Canada. The facility will produce electricity from an ORC system* utilizing Turboden&rsquo;s technology, with biomass fuel derived from residual wood waste from the adjacent, MLTC-owned NorSask Forest Products LP sawmill as heating fuel.</p>
<p>The system is expected to produce 6,600kW (net) of carbon-neutral baseload electricity to power approximately 5,000 homes. The project is expected to decrease greenhouse gas emissions by more than one million metric tons over 25 years (equivalent to CO2 emission of more than 50,000 vehicles per year), as well as significantly reduce smoke and other harmful particulate matter, improving the local air quality conditions.</p>
<p>In addition to the generated electricity, the cogeneration system design provides process heat to the NorSask sawmill buildings as well as new high-efficiency lumber dry kiln, which will reduce natural gas consumption and also improve the economics of Canada's largest 100 percent Indigenous-owned sawmill facility.</p>
<p>Turboden was founded in 1980 by professors from Polytechnic University of Milan and has been focused on the use of ORC power generation systems. The company became part of MHI Group in 2013. In 2016, Turboden signed a contract with general machinery trading company Daiichi Jitugyo making the firm its sales distributor in Japan.</p>
<p>In October, Turboden's 995 kW ORC cycle power generation system was adopted for a project in Nankan-machi (Kumamoto Prefecture) using bamboo biomass, as the primary fuel, which had been considered difficult to process in Japan. As the first such initiative in Japan, the project is supported by Japan&rsquo;s national research and development agency, the New Energy and Industrial Technology Development Organization, which is seeking to promote the introduction of biomass energy.</p>
<p>MHI, as a global corporation that provides wide-ranging and highly efficient power generation and energy systems, will work closely with Turboden to continue the successful adoption of binary cycle power generation systems globally, contributing to a more sustainable energy mix.</p>
<p><em>*Turboden&rsquo;s binary cycle power generation system has as its core component an Organic Rankine Cycle turbine, which uses as the boiling medium organic material with a low boiling point, such as a fluorocarbon or hydrocarbon-based material. This permits the use of relatively low-temperature heat sources such as biomass, factory waste heat and geothermal energy. The system can generate up to 40,000kW of electricity, and can be easily installed in nonfuel-producing regions or areas lacking water resources, such as inland areas, deserts and islands. It is also able to provide stable power generation without being subject to the weather or other factors.</em></p></div><div class="ad"><div class="advertisement">ADVERTISEMENT</div> <script type="text/javascript">OA_show("med_rectangle_2");</script></div><div style="margin:20px 0; width:100%; height:210px; display:block;"><h3>Related Articles</h3><div style="width:50%; display:inline; height:60px; float:left;"><a href="/articles/16799/brightmark-to-build-dairy-rng-project-in-south-dakota" style="font-size:14px;"><img src="/uploads/posts/web/2020/02/dairyCow_1581111729854_thumb.jpeg" style="float:left; margin:0 5px 5px 0;" />Brightmark to build dairy RNG project in South Dakota</a></div><div style="width:50%; display:inline; height:60px; float:left;"><a href="/articles/16798/greenlane-signs-system-supply-contract-with-rngc" style="font-size:14px;"><img src="/uploads/posts/web/2020/02/GreenlaneLogo_15811116420637_thumb.jpg" style="float:left; margin:0 5px 5px 0;" />Greenlane signs system supply contract with RNGC</a></div><div style="width:50%; display:inline; height:60px; float:left;"><a href="/articles/16779/greenlane-to-finance-biogas-upgrading-systems-in-europe" style="font-size:14px;"><img src="/uploads/posts/web/2020/01/GreenlaneLogo_15804228679228_thumb.jpg" style="float:left; margin:0 5px 5px 0;" />Greenlane to finance biogas upgrading systems in Europe </a></div><div style="width:50%; display:inline; height:60px; float:left;"><a href="/articles/16773/innogy-sells-german-biomass-cogeneration-plant-pellet-facility" style="font-size:14px;"><img src="/uploads/posts/web/2020/01/InnogyGermany1_15802521077715_thumb.jpg" style="float:left; margin:0 5px 5px 0;" />Innogy sells German biomass cogeneration plant, pellet facility </a></div><div style="width:50%; display:inline; height:60px; float:left;"><a href="/articles/16769/nv-energy-seeks-proposals-for-renewable-energy-projects" style="font-size:14px;"><img src="/uploads/posts/web/2020/01/PowerLines3_15799012969119_thumb.JPG" style="float:left; margin:0 5px 5px 0;" />NV Energy seeks proposals for renewable energy projects</a></div><div style="width:50%; display:inline; height:60px; float:left;"><a href="/articles/16767/doe-offers-96-million-for-bioenergy-rd-projects" style="font-size:14px;"><img src="/uploads/posts/web/2020/01/DOELogoBigger_15798172203023_thumb.jpg" style="float:left; margin:0 5px 5px 0;" />DOE offers $96 million for bioenergy R&D projects</a></div><div class="clearFix">&nbsp;</div></div>
			
<div class="clearFix">&nbsp;</div>
</div> <!-- end .post -->


<div class="clearFix">&nbsp;</div>
	<div id="colRight">
		
		<div class="social">		
			<div align="center">
<!-- Begin MailChimp Signup Form -->
<link href="//cdn-images.mailchimp.com/embedcode/slim-10_7.css" rel="stylesheet" type="text/css">
<style type="text/css">
                #mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif; }
                /* Add your own MailChimp form style overrides in your site stylesheet or in this style block.
                   We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style>
<div id="mc_embed_signup">
<form action="//onsiteenergymanager.us12.list-manage.com/subscribe/post?u=affe8bf6b5232eca3c2c1b325&amp;id=53880fe73c" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
    <div id="mc_embed_signup_scroll">
                <label for="mce-EMAIL">Join Our Mailing List</label>
                <input type="email" value="" name="EMAIL" class="email" id="mce-EMAIL" placeholder="email address" required>
    <!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups-->
    <div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_affe8bf6b5232eca3c2c1b325_53880fe73c" tabindex="-1" value=""></div>
    <div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
    </div>
</form>
</div>

<!--End mc_embed_signup-->

		</div>
		
		<!-- <div class="advertisement">ADVERTISEMENT</div>
		<script type='text/javascript'>
		    OA_show('med_rectangle_2');
		</script> -->
		
		<div class="advertisement">ADVERTISEMENT</div>
		<script type='text/javascript'>
		    OA_show('skyscraper');
		</script>
		
	</div>









	
		<span class="clearFix">&nbsp;</span>
		</div>
	</div>		
	<div id="bottomAd">	
		<div class="advertisement">ADVERTISEMENTS</div>
		<div style="width:320px; text-align:left; display:block; float:left; height:100px;"><script type='text/javascript'>OA_show('rectangle_1');</script></div>
		<div style="width:320px; text-align:center; display:block; float:left; height:100px;"><script type='text/javascript'>OA_show('rectangle_2');</script></div>
		<div style="width:320px; text-align:right; display:block; float:left; height:100px;"><script type='text/javascript'>OA_show('rectangle_3');</script></div>
		<span class="clearFix"></span>
	</div>
</div>
<div id="footer">
	<div id="logoFooter">
		<div class="content">
			<a href="/" class="logo"><img src="/img/layout/footerLogo.jpg"></a>
			<div class="links">
				<ul class="siteLinks">
					<li><a href="/">Home</a></li>
					<li><a href="/pages/subscribe/">Subscribe Now</a></li>
					<li><a href="/pages/advertising/">Advertising</a></li>
					<li><a href="/issues/browse/">Magazine</a></li>
					
					<li><a href="/newsletter/">E-Newsletter</a></li>
					<li><a href="/events/browse/">Events</a></li>
					<li><a href="/pages/about/">About Us</a></li>
					<li class="last"><a href="/pages/contact/">Contact Us</a></li>
				</ul>
				<ul>
					<li><a href="http://www.biomassmagazine.com/" target="_blank">Ethanol Producer Magazine</a></li>
					<li class="last"><a href="http://www.biodieselmagazine.com/" target="_blank">Biodiesel Magazine</a></li>
				</ul>
			</div>
		</div>
	</div>
	<div id="creditsFooter">
		<div class="content">
			<div class="credits">
				<img src="/img/layout/bbiFooter.jpg">
				<span>&copy; Copyright 2020 - BBI International - All rights reserved.</span>
			</div>
		</div>
	</div>
</div>

<script type="text/javascript">

  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-20877925-4']);
  _gaq.push(['_setDomainName', '.biomassmagazine.com']);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>

</body>
</html>


		
		